sábado, 11 de febrero de 2017

Configuración de direccionamiento IPv4 y subredes

Veremos los conceptos básicos de direccionamientos IP, y una práctica de red con una topología real de redes de datos, verificaremos su funcionamiento y revisaremos los comandos para ver su funcionamiento.

2.1 Objetivos


·        Práctica de direccionamiento IP
·        Práctica de VLSM
·        Práctica de sumarización de rutas
·        Revisión de comandos para verificar y solucionar problemas de direccionamiento IPv4

2.2 Conceptos de IPv4


2.2.1 Convertir de decimal a binario






   

Para convertir un número decimal a un número binario, se deben activar los bits en 1, hasta alcanzar el número decimal deseado, por ejemplo:

              192 = 11000000 = 128+64 à Nro. Decimal = 192 à  Nro. Binario = 11000000
168 = 10101000 = 128 + 0+ 32+ 0 + 8 à Nro. Decimal = 168 à  Nro. Binario = 10101000
               221 = ¿Cuál es el número binario?


2.2.2 Convertir de binario a decimal

Para convertir un número binario en decimal, se deben agregar los bits que se han activado (1s), por ejemplo:
             10101100 = 128 + 0 + 32 + 0 + 8 + 4 = 172
             00010000 = 0 + 0 + 0 + 16
             10101010 = ¿Cuál es el número decimal?



2.2.3 Cálculo de subredes VLSM

Creación de subred de 30 host – Red base 192.168.0.0
Fórmula cálculo de host à 2n – 2 ≥ 30 à n=5 à 25  - 2 = 32 – 2 = 30 host
Máscara à 11111111.11111111.11111111.11100000 (24 bit de red + 3 bit de subred + 5 bit de host (bits en 0))
Máscara à 255.255.255.224

Creación de subred con 14 host – Red base 192.168.0.0
Fórmula cálculo de host à 2n – 2 ≥ 14 à n=4 à  24  - 2 = 16 -2 = 14 host
Máscara à 11111111.11111111.11111111.11110000 (24 bit de red + 4 bit de subred + 4 bit de host (bits en 0))
Máscara à 255.255.255.240

Creación de subred con 62 host – Red base 192.168.0.0 (¿Cuál es la máscara?)
Fórmula cálculo de host à 2n – 2 ≥ 62 à n=? à  2?  - 2 = ? -2 = 62 host
Máscara à 11111111.11111111.11111111.???????? (24 bit de red + ? bit de subred + ? bit de host (bits en 0))
Máscara à 255.255.255.?




2.2.4 Resumen subred IPv4





   2.2.5 Sumarización de rutas:

Es una técnica empleada para agrupar múltiples rutas IP contiguas en una única ruta, de tal manera de reducir la cantidad de rutas en una tabla de enrutamiento de un router, aumenta la estabilidad ya que permanece estable mientras al menos una de las rutas sumarizadas permanezca activa, además reduce la cantidad de memoria RAM y procesador  usada en la tabla de enrutamiento.

Un ejemplo de sumarización de rutas:

            172.16.0.0/24 = 10101100.00010000.00000000.000000000 à Ruta presente en red local
            172.16.1.0/24 =10101100.00010000.00000001.000000000 à Ruta presente en red local
            172.16.2.0/24 =10101100.00010000.00000010.000000000 à Ruta presente en red local
   172.16.3.0/24 =10101100.00010000.00000011.000000000 à Ruta presente en red local
Bit común:   10101100.00010000.000000 --> /22
Ruta sumarizada y publicada hacia el exterior:
172.16.0.0/22

Realice la siguiente práctica de sumarización de rutas:
10.0.0.0/24 =
10.0.1.0/24 =
10.0.2.0/24 =
10.0.3.0/24 =
10.0.4.0/24 =
10.0.5.0/24 =
10.0.6.0/24 =
10.0.7.0/24 =
Bit común: ?.?.? à /?
Ruta sumarizada y publicada hacia el exterior:
10.0.?.?/?



2.3 Práctica de IPv4


Las prácticas de este libro fueron realizadas con “Cisco Packet Tracer”, si deseas saber más de Packet Tracer, te dejo este link para un video curso con un descuento especial por haber adquirido este libro.


2.3.1 Diagrama topológico:






2.3.2 Configuración – Tabla de Direccionamiento IP





2.3.3 Configuración Router1

Router>ena
Router# config t
Router(config)#hostname Router1
Router1(config)#enable secret cisco
Router1(config)#line console 0
Router1(config-line)#login
Router1(config-line)#password cisco
Router1(config-line)#exit
Router1(config)#line vty 0 15
Router1(config-line)#login
Router1(config-line)#password cisco
Router1(config-line)#exit
Router1(config)# interface FastEthernet0/0
Router1(config-if)# ip address 192.168.0.1 255.255.255.224
Router1(config-if)# interface FastEthernet0/1
Router1(config-if)# ip address 192.168.0.33 255.255.255.240
Router1(config-if)# interface FastEthernet1/0
Router1(config-if)# ip address 192.168.0.49 255.255.255.248
Router1(config-if)# interface Serial0/0
Router1(config-if)# ip address 192.168.0.57 255.255.255.252
Router1(config-if)#exit
Router1(config)# ip route 172.16.0.0 255.255.252.0 192.168.0.58
Router1(config)#exit
Router1# copy running-config startup-config


2.3.4 Configuración Router2

Router>ena
Router# config t
Router(config)#hostname Router2
Router2(config)#enable secret cisco
Router2(config)#line console 0
Router2(config-line)#login
Router2(config-line)#password cisco
Router2(config-line)#exit
Router2(config)#line vty 0 15
Router2(config-line)#login
Router2(config-line)#password cisco
Router2(config-line)#exit
Router2(config)# interface FastEthernet0/0
Router2(config-if)# ip address 172.16.0.1 255.255.255.0
Router2(config-if)# interface FastEthernet0/1
Router2(config-if)# ip address 172.16.1.1 255.255.255.0
Router2(config-if)# interface FastEthernet1/0
Router2(config-if)# ip address 172.16.2.1 255.255.255.0
Router2(config-if)# interface Serial0/0
Router2(config-if)# ip address 192.168.0.58 255.255.255.252
Router2(config-if)# exit
Router2(config)# ip route 192.168.0.0 255.255.255.224 192.168.0.57
Router2(config)# ip route 192.168.0.32 255.255.255.240 192.168.0.57
Router2(config)# ip route 192.168.0.48 255.255.255.248 192.168.0.57
Router2(config)# exit
Router2# copy running-config startup-config


En el Router2 podemos sumarizar las redes de la siguiente forma:

192.168.0.0/27  à 11000000. 10101000.00000000.00000000
192.168.0.32/28 à 11000000. 10101000.00000000.00100000
192.168.0.48/29 à 11000000. 10101000.00000000.00110000
Bit común:   11000000. 10101000.00000000.00 --> /26
Ruta sumarizada y publicada hacia el exterior:
192.168.0.0/26


Por lo que podemos crear una única ruta hacia estas tres redes, de la siguiente forma:

Router2(config)# no ip route 192.168.0.0 255.255.255.224 192.168.0.57
Router2(config)# no ip route 192.168.0.32 255.255.255.240 192.168.0.57
Router2(config)# no ip route 192.168.0.48 255.255.255.248 192.168.0.57
Router2(config)# ip route 192.168.0.0 255.255.255.192 192.168.0.57 à Ruta sumarizada
Router2# copy running-config startup-config


2.3.5 Configuración de PC

PC0
IP:                                     192.168.0.10
Máscara de subred:      255.255.255.224
Default Gateway:         192.168.0.1

PC1
IP:                                     192.168.0.42
Máscara de subred:      255.255.255.240
Default Gateway:         192.168.0.33

PC2
IP:                                     192.168.0.54
Máscara de subred:      255.255.255.248
Default Gateway:         192.168.0.49

PC3
IP:                                     172.16.0.10
Máscara de subred:      255.255.255.0
Default Gateway:         172.16.0.1

PC4
IP:                                     172.16.1.10
Máscara de subred:      255.255.255.0
Default Gateway:         172.16.1.1

PC5
IP:                                     172.16.2.10
Máscara de subred:      255.255.255.0
Default Gateway:                        172.16.2.1


2.3.6 Pruebas de conexión

Ping desde PC0 a PC1, PC2, PC3, PC4 y PC5
Ping desde PC1 a PC0, PC2, PC3, PC4 y PC5
Ping desde PC2 a PC0, PC1, PC3, PC4 y PC5
Ping desde PC3 a PC0, PC1, PC2, PC4 y PC5
Ping desde PC4 a PC0, PC1, PC2, PC3 y PC5
Ping desde PC5 a PC0, PC1, PC3, PC3 y PC4

Ejemplo Ping desde PC0 a PC1 à Exitoso
C:\>ping 192.168.0.42
Pinging 192.168.0.42 with 32 bytes of data:
Reply from 192.168.0.42: bytes=32 time=1ms TTL=127
Reply from 192.168.0.42: bytes=32 time<1ms TTL=127
Reply from 192.168.0.42: bytes=32 time<1ms TTL=127
Reply from 192.168.0.42: bytes=32 time<1ms TTL=127
Ping statistics for 192.168.0.42:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms


2.3.7 Comandos de troubleshooting

·        Sh ip interface brief
·        Sh run
·        sh ip route


2.3.7.1 Resultados Router1

Router1#show ip interface brief
Interface                            IP-Address          OK? Method       Status                                 Protocol
FastEthernet0/0               192.168.0.1        YES manual         up                                        up
FastEthernet0/1               192.168.0.33      YES manual         up                                        up
Serial0/0                            192.168.0.57      YES manual         up                                        up
FastEthernet1/0               192.168.0.49      YES manual         up                                        up
FastEthernet1/1               unassigned         YES unset            administratively down    down




Router1#sh run

Building configuration...
Current configuration : 822 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router1
!

no ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.224
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.33 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.0.57 255.255.255.252
clock rate 2000000
!
interface FastEthernet1/0
ip address 192.168.0.49 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
ip classless
ip route 172.16.0.0 255.255.252.0 192.168.0.58
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end


Router1# sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/22 is subnetted, 1 subnets
S       172.16.0.0 [1/0] via 192.168.0.58
     192.168.0.0/24 is variably subnetted, 4 subnets, 4 masks
C       192.168.0.0/27 is directly connected, FastEthernet0/0
C       192.168.0.32/28 is directly connected, FastEthernet0/1
C       192.168.0.48/29 is directly connected, FastEthernet1/0
C       192.168.0.56/30 is directly connected, Serial0/0


2.3.7.2 Resultados Router2

Router2#sh ip interface brief
Interface                             IP-Address          OK? Method                     Status                Protocol
FastEthernet0/0                172.16.0.1          YES manual                      up                    up
FastEthernet0/1                172.16.1.1          YES manual                      up                    up
Serial0/0                              192.168.0.58    YES manual                       up                    up
FastEthernet1/0               172.16.2.1           YES manual                      up                    up
FastEthernet1/1                unassigned         YES unset                          administratively down down


Router2#sh run

Router2#sh run
Building configuration...

Current configuration : 794 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router2
!
no ip cef
no ipv6 cef
!
interface FastEthernet0/0
 ip address 172.16.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.0.58 255.255.255.252
interface FastEthernet1/0
 ip address 172.16.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
ip classless
ip route 192.168.0.0 255.255.255.192 192.168.0.57
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end


Router2#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.0.0 is directly connected, FastEthernet0/0
C       172.16.1.0 is directly connected, FastEthernet0/1
C       172.16.2.0 is directly connected, FastEthernet1/0
     192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
S       192.168.0.0/26 [1/0] via 192.168.0.57
C       192.168.0.56/30 is directly connected, Serial0/0



Cualquier duda, solo escribela en este blog y será respondida.

Para un curso completo sobre direccionamiento IP, puedes encontrar un descuento acá





Síguenos también en:


Facebook | Twitter | Google + Youtube Cursos





Regístrate a nuestros contenidos

* indicates required


No hay comentarios:

Publicar un comentario